Skip Navigation

Documents in Portable Document Format (PDF) require Adobe Acrobat Reader 5.0 or higher to view. Download Adobe© Acrobat Reader.

What types of Internet browsers can I use to access my accounts online?

Use one of the following supported browsers:

  • PC
    Microsoft Internet Explorer (IE) Version 7.0 – 8.0*
    Firefox Version 3 and Higher
    Google Chrome
    *IE 8.0 includes a compatibility view feature that displays websites that were created for older browsers as they were designed to appear. Current testing of IE 8.0 with this feature enabled has provided acceptable results. IE 8.0 is a supported browser when this feature is enabled.

  • MAC
    Safari Version 1.0 and Higher
    Firefox Version 3 and Higher
    Google Chrome


What if I am not using one of the supported browsers?

You may experience issues with internet banking. If this occurs, please download one of the browsers listed and attempt the action again.


Can I use a Beta version of one of the Browsers above?

We do not recommend using a Beta version of any browser. When new versions of browsers are fully tested and deemed compatible with the Internet Banking product, they will be updated on the supported browsers list.

The following types of browsers and tools are not recommended or supported for use with Internet Banking:

  • Embedded Browsers contained within Personal or Commercial Financial Management Software (Quicken, Quickbooks, Money, etc.)
  • Browser Add-Ins and Toolbars (IE 7 Pro, Google, Yahoo, etc.)
If you are using a non-supported browser, an embedded browser, or a browser add-in, you may experience functionality issues with Internet Banking. If this occurs, please download one of the browsers listed above or remove the add-in and attempt the action again.